Account verification emails are not always delivered
Resolved
Mar 03 at 08:47pm EST
We have contacted Microsoft and are pursuing next steps with them. We have added a banner directly to our email verification page to alert new Microsoft users of this issue and potential workarounds. We will keep the email verification page up to date with the latest information for any new users experiencing this issue.
Affected services
Tango Web Application
Updated
Mar 03 at 07:49pm EST
Update -- This issue appears to be specifically impacting users with Microsoft email clients, such as Office 365. We have potential multiple solutions in progress.
If you're not receiving your account verification email, please check your Junk folder or ask your IT admin to check for quarantined emails. Thank you for your patience as we work on a fix.
Tango's main functionalities are not affected.
Affected services
Tango Web Application
Created
Mar 02 at 11:27am EST
New users who sign up with email and password may not receive account verification emails or they may be sent to the Spam folder. Please try the steps in this FAQ: https://help.tango.us/en/articles/6081759-i-m-not-getting-the-tango-verification-email
If you’re still unable to find the verification email, please contact Support to verify your account. We apologize for the inconvenience.
Affected services
Tango Web Application