Back to overview
Degraded

Slow website performance

Mar 28 at 03:24pm EDT
Affected services
Tango Web Application

Resolved
Mar 28 at 03:35pm EDT

We have identified the root cause of the issue and a fix was deployed.

Users should be able to create workflows again.

Created
Mar 28 at 03:24pm EDT

We are aware of slow website performance and are investigating the root cause. Some users are unable to create workflows.

Our team is working to address the issue and we appreciate your patience as we work to resolve it.